Read this before upgrade to vCenter 6.0 U2a (Windows)

Read this before upgrade to vCenter 6.0 U2a (Windows)

Recently I had to upgrade from vCenter 6.0 U2 to 6.0 U2a because of this WebClient Bug (KB 2144934)

But there are many stumbling blocks I would like to inform you about!

I cannot say it enough, backup AND snapshot your vCenter before!

In this release there are so many stumbling blocks where the upgrade could fail!

Here are some examples:

After some upgrade intentions the “VMware Workflow Manager” Service did not start anymore. Look at the “workflow-manager.log”

In the log you can find the following (C:\ProgramData\VMware\vCenterServer\logs\workflow\workflow-manager.log):

 

My prefered approach in cooperation with VMware Support is the following:

  1. Have a vCenter Backup
  2. Have a vCenter Snapshot (In powered off state)
  3. Uninstall the Antivirus Client (In my case Symantec Endpoint Protection), reboot  (VMware Support recommendation)
  4. Clear %temp% Folder
  5. Install any Windows Update and reboot
  6. Install Process Explorer and look for “vmeventmsg.dll”, kill the process if it’s in use (VMware Support recommendation)
  7. Install yourCD-Drive:\vCenter-Server\Packages\VMware-python.msi (VMware Support recommendation)
  8. Copy all Installation Files to a local folder eg. c:\temp\install-vc60u2a\ (VMware Support recommendation)
  9. Try the upgrade with the wizard

Even though I followed this procedure, the upgrade failed. Also the Workflow Manager Service didn’t start anymore. Without a reboot the upgrade went trough the second time.

puhhh 🙂

Hopefully this was the last Windows vCenter upgrade in my life! Continue with VCSA 😉

11 thoughts on “Read this before upgrade to vCenter 6.0 U2a (Windows)

  1. To fix the issue try the below steps
    D:\ProgramData\VMware\vCenterServer\cfg\vmware-vpx-workflow\conf\workflow.properties:

    Replace the line :

    workflow.jmx.port=-1

    TO

    workflow.jmx.port= 19999

  2. Thanks !

    ….. My setup was failing. I was on a local disk but not C: !
    I moved the setup files to c:\temp and all went fine.

    1. Not until yet.
      My plan is to move to 6.5 directly but I have to migrate from Nexus 1000v before :/

Leave a Reply

Your email address will not be published. Required fields are marked *