How to: UCS to MDS Port Channel

How to: UCS to MDS Port Channel

The last Days I want to create a Port Channel between my UCS Chassis and my MDS Switch. See how to configure and get some hints.

Remember, during this configuration you loose one FC-Uplink! So check if your Blades see the Paths over both Fabrics!


On my first try I didn’t get it up. This had to do with the old Firmware of my MDS Switches. So we had to Upgrade to 6.X Release. (https://supportforums.cisco.com/discussion/11896686/create-port-channel-between-ucs-fi-and-mds-9124-f-mode)

At the second starting point I go with the following Versions:

  • Cisco UCS 2.2.(7c)
  • Cisco MDS 6.2(19)

Before we create the Channel we have to check:

  • Cisco MDS
    • Feature npiv (enabled)
    • Feature fport-channel-trunk (enabled)
    • Put both ports fot the Channel in the same VSAN

Check Feature:

san-1b# show feature
Feature Name          Instance  State
--------------------  --------  --------
dpvm                  1         disabled
evmed                 1         disabled
fabric-binding        1         disabled
fcsp                  1         disabled
fport-channel-trunk   1         enabled
http-server           1         enabled
ioa                   1         disabled
isapi                 1         disabled
ivr                   1         disabled
ldap                  1         disabled
npiv                  1         enabled
npv                   1         disabled
onep                  1         disabled
poap                  1         disabled
port-security         1         disabled
port_track            1         disabled
privilege             1         disabled
qos-manager           1         disabled
scheduler             1         disabled
scpServer             1         disabled
sdv                   1         disabled
sfm                   1         disabled
sftpServer            1         disabled
sshServer             1         enabled
tacacs                1         disabled
telnetServer          1         disabled
tpc                   1         disabled
san-1b#

Enable Feature:

san-1b# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
san-1b#(config)# feature fport-channel-trunk
Admin trunk mode has been set to off for
1- Interfaces with admin switchport mode F,FL,FX,SD,ST in admin down state
2- Interfaces with operational switchport mode F,FL,SD,ST.

At the next Step we configure the PortChannel in the UCS GUI:

Go to “SAN” Tab, “Create Port Channel”, Add ID and a Name, Add Ports, Finish.

After creating, Disable Port Channel and choose VSAN if you do not use the default VSAN1.

I use the UCS Ports 25+27 in VSAN 3370


So now let’s configure the MDS Switch:

I use the MDS Ports 10+24 in VSAN 3370

san-1b# conf t
san-1b(config)# 
san-1b(config)# interface fc1/10
san-1b(config-if)# shutdown
san-1b(config-if)# switchport mode F
san-1b(config-if)# channel-group 31
fc1/10 added to port-channel 31 and disabled
please do the same operation on the switch at the other end of the port-channel,
then do "no shutdown" at both ends to bring it up
san-1b(config-if)# 
san-1b(config-if)# interface fc1/24
san-1b(config-if)# shutdown
san-1b(config-if)# switchport mode F
san-1b(config-if)# channel-group 31
fc1/24 added to port-channel 31 and disabled
please do the same operation on the switch at the other end of the port-channel,
then do "no shutdown" at both ends to bring it up
san-1b(config-if)# 
san-1b(config-if)# interface port-channel 31
san-1b(config-if)# shutdown
san-1b(config-if)# switchport mode F
san-1b(config-if)# channel mode active

Now enable the Port Channel in UCS GUI and go back to MDS.

san-1b(config-if)# no shutdown
san-1b(config-if)# show interface port-channel 31

port-channel31 is up
    Hardware is Fibre Channel 
    Port WWN is 24:1f:00:05:73:b1:3c:68
    Admin port mode is F, trunk mode is on
    snmp link state traps are enabled
    Port mode is F
    Port vsan is 3370
    Speed is 16 Gbps
    admin fec state is down
    oper fec state is down
    5 minutes input rate 224960624 bits/sec,28120078 bytes/sec, 16141 frames/sec
    5 minutes output rate 145118008 bits/sec,18139751 bytes/sec, 13232 frames/sec
      98643 frames input,152616864 bytes
        0 discards,0 errors
        0 invalid CRC/FCS,0 unknown class 
        0 too long,0 too short
      118603 frames output,166967868 bytes
        0 discards,0 errors
      0 input OLS,0  LRR,0 NOS,0 loop inits
      0 output OLS,0 LRR, 0 NOS, 0 loop inits
    Member[1] : fc1/10
    Member[2] : fc1/24
    Interface last changed at XXXXXXXXXXXXXX

san-1b(config-if)# wr
Copy complete.
san-1b(config-if)#

If the Channel does not come up, check if your Ports are up! Maybe you have to do a “no shutdown” on the interface.

(config-if)# show interface brief 

-------------------------------------------------------------------------------
Interface  Vsan   Admin  Admin   Status       SFP    Oper  Oper   Port
                  Mode   Trunk                       Mode  Speed  Channel
                         Mode                              (Gbps)
-------------------------------------------------------------------------------
fc1/1      1000   auto   on      trunking     swl   TE     8      1        
fc1/2      1000   auto   on      trunking     swl   TE     8      1  
----      
fc1/10     3370   F      on      up           swl   F      8      31 
----
fc1/24     3370   F      on      up           swl   F      8      31       

Back to GUI. You should see that the Channel is up.


Enjoy and share 😉 !

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close